FinPinKin
15.08.2020 23:43

Напишите программу, подсчитывающую количество букв во введенной строке (слове).

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
pogoreiko
01.10.2020 22:50
Var
  s: string;
  letters: set of 'А'..'я';
  i, n: integer;

begin
  writeln('Введите текст');
  readln(s);
  n := 0;
  letters := ['А'..'я'];
  for i := 1 to length(s) do
    if s[i] in letters then n := n + 1;
  writeln('Количество букв в строке: ', n);
end.

Тестовое решение:

Введите текст
Это текст содержащий буквы, цифры (1,2,3,4), латиницу werwer sxFFSFw и зн"ачки [email protected]#$%#^
Количество букв в строке: 43
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота