Gorodnichevavi
16.04.2020 10:04

Написать программу,составить алгоритм вычисления среднего арифметического значения массива из 15 целых чисел. числа вводить с использованием генератора случайных чисел. итоговая оценка

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
arinamarkina0
01.10.2020 22:45
Var
  i,n:integer;
  s:real;
begin
  Randomize;
  writeln('Исходные числа');
  s:=0;
  for i:=1 to 15 do begin
    n:=random(100)-50;
    write(n:4);
    s:=s+n
    end;
  s:=s/15;
  writeln;
  writeln('Среднее арифметическое равно ',s)
end.

Тестовое решение:

Исходные числа
  -5 -41 -36  44  -2   8 -24  10   0  20  -8  15  14  35  44
Среднее арифметическое равно 4.93333333333333
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота