pachev
14.10.2020 16:55

Составить программу, определяющую, в каком из данных 5 чисел количество цифр больше. нахождение количество цифр числа оформить в виде функции решение на паскале, написать программу

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Простоелена26
07.07.2020 23:01
function len(a: integer): byte;
begin
  result := Length(IntToStr(a));
end;

var
  a, b: integer;

begin
  for i: byte := 1 to 5 do //Убрав цикл, можно сэкономить память, не знаю насчёт ресурсов ЦП, но с циклом красивее
  begin
    readln(a);
    if (len(a) > len(b)) then
      b := a;
  end;
  writeln(b);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота