Selid
07.07.2022 11:38

Написать программу которая складывает числа до тех пор пока не получится число состоящее из одной цифры. пример: 5+5+5=15=1+5=6 он должен ответ складывать так как показано в примере как это сделать я не как не могу понять(

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
stanvadrem
07.07.2020 20:22
Var
  a, b: integer;

begin
  readln(a);
  while (inttostr(a).Length > 1) do
  begin
    b := 0;
    foreach c: char in inttostr(a) do
      b += strtoint(c);
    a := b;
  end;
  writeln(b);
end.

var
  a, b, e: integer;
  d: string;

begin
  readln(a);
  d := inttostr(a);
  while (length(d) > 1) do
  begin
    d := inttostr(a);
    b := 0;
    for e := 1 to length(d) do
      b += strtoint(d[e]);
    a := b;
  end;
  writeln(b);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота