Voina2022
10.04.2022 11:33

Написать программу замены положительных элементов вещественного массива y[1..n] на 0. (паскаль-массивы)

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
ник5047
07.07.2020 19:05
Решение в файле

uses crt;
var a: array of integer;    n, i: integer;    begin
WriteLn('Введите N');ReadLn(n);
a := new integer[n];
randomize; //заполняем массив случайными значениямиfor i:=0 to n-1 dobegina[i]:=random(100)-50;Write(a[i]:5);end;Writeln;
for i:=0 to n-1 do //заменяем положительные элементы нулемbeginif a[i]>0 then a[i]:=0;Write (a[i]:5);end;writeln;readln;end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота