Smekalenok
05.05.2020 22:38

Напишите программу для pascal 1) пользователь вводит число, количество цифр в нем неизвестно, но последняя цифра = 0. посчитать количество четных положительных цифр в этом числе. 2)пользователь вводит число, посчитать количество цифр в числе и вывести минимальную цифру.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
vladgubin78
01.10.2020 22:19
Program Ex1;

var
  s: string;
  c: char;
  i, n, m, min: integer;

begin
  s := '';
  m := 0;
  n := 0;
  min := 10;
  writeln('Введите число');
  repeat
    read(c);
    s := s + c;
    i := StrToInt(c);
    if i mod 2 = 0 then
      if c <> '0' then m := m + 1;
    // для задания 2)
    n := n + 1;
    if i < min then min := i
  until c = '0';
  writeln('Введено число ', s, ', в нем четных цифр- ', m)
end.

program Ex2;

var
  s: string;
  i, d, n, min: integer;

begin
  min := 10;
  writeln('Введите число');
  readln(s);
  n := length(s);
  for i := 1 to length(s) do
  begin
    d := StrToInt(s[i]);
    if d < min then min := d
  end;
  writeln('Введено число ', s, ', в нем цифр- ', n, ', минимальная- ', min)
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота