Напишите программу, которая выполняет циклический сдвиг части массива, начиная с элемента с номером k и заканчивая элементом с номером m(включительно), влево на r элементов.
Var i,k,m,r,p,j:integer; a:array[1..10]of integer; begin writeln('Массив: '); for i:=1 to 10 do begin a[i]:=random(10); write(a[i],' '); end; writeln; write('Введите K,M,R: '); readln(k,m,r); for i:=1 to r do begin j:=k; p:=a[j]; while j<m do begin a[j]:=a[j+1]; j:=j+1 end; a[j]:=p; end; writeln('Измененный массив:'); for i:=1 to 10 do write(a[i],' '); end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку