konovalova701
29.11.2022 20:33

Напишите программу, которая выполняет реверс части массива, начиная с элемента с номером k и заканчивая элементом с номером m(включительно).

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
artemka106
07.07.2020 13:14
Var
  i,k,m,j:integer;
  a,b:array[1..10]of integer;
begin
writeln('Исходный массив:');
for i:=1 to 10 do
  begin
  a[i]:=random(50);
  write(a[i]:3);
  end;
writeln;
write('Введите k и m: ');
readln(k,m);
j:=m;
for i:=k to m do
  begin
  b[j]:=a[i];
  j:=j-1;
  end;
for i:=k to m do  a[i]:=b[i];
writeln('Измененный массив:');
for i:=1 to 10 do  write(a[i]:3);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота