hockeymen228
13.02.2021 22:22

Program_v1; var a: array [1..20] of integer; i,s: integer; begin randomize; s: =0; for i: =1 to 20 do begin a[i]: =random(100); write (' ',a[i] '); end; for i: =1 to 20 do if imod2> 0 then s: = a[i]*a[i]; writeln; writeln('s=',s); readln; end. генератором случайных чисел (от 0 до 100) задан массив из 20 целых чисел.составьте программу, с которой напечатайте на одной строчке исходный массив, а на следующей строке - сумму квадратов элементов с начетными индексами я верно написала программу и у кого есть паскаль, , проверьте верно ли она работает!

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
shumilovakate
01.10.2020 21:26
Не проверяя говорю, что тут ошибка:
s: = a[i]*a[i];
Надо найти сумму, а тут просто присваивается квадратов. Надо написать вот так
S:= s + sqr(a[i]);
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота