bengamin1993
19.04.2021 21:14

Напишите программу в среде программирования турбо паскаль, которая в последовательности натуральных чисел вычисляет сумму всех однозначных чисел, кратных 3. программа получает на вход натуральные числа, количество введенных чисел неизвестно, последовательность чисел заканчивается числом 0 (0-признак окончания ввода, не входит в последовательность). количество чисел не превышает 1000. введенные числа не превышают 30000. программа должна вывести одно число: сумму всех однозначных чисел, кратных 3.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
nyk156
07.07.2020 07:01
Var  s,n:integer;
begin
  repeat
  readln(n);
  if (n mod 3=0) and (n<10) then s:=s+n;
  until n=0;
writeln('S=',s);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота