antonzagarinp00ule
21.08.2021 14:48

Тема: массивы ! написать программу расчета среднего арифметического отрицательных элементов в одномерном массиве. заменить минимальный элемент в одномерном массиве на полученное среднее арифметическое.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
krutikovaelizaozax2f
07.07.2020 06:54
Var
  i,n:integer;
  s,min:real;a:array[1..10]of real;
begin
writeln('Исходный массив:');
for i:=1 to 10 do
  begin
  a[i]:=random(-10,10);
  write(a[i],' ');
  if a[i]<0 then
     begin
     s:=s+a[i];
     n:=n+1;
     end;
  if a[i]<min then min:=a[i];
  end;
writeln;
s:=s/n;
for i:=1 to 10 do  if a[i]=min then a[i]:=s;
writeln('Среднее отрицательных:',s);
writeln('Измененный массив:');
for i:=1 to 10 do  write(a[i],' ');
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота