Составьте программу для pascal abc, решающую следующую . у продавца имеются гири весом 1, 2, 5 кг. наберите минимальное кол-во гирь для взвешивания n кг.
Program z1; var n:integer; s1,s2,s5:integer; begin write('n=');readln(n); s5:=n div 5;n:=n mod 5; s2:=n div 2;s1:=n mod 2; writeln('5 kg-',s5,'; 2 kg-',s2,'; 1 kg-',s1); readln end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку