deisika7
29.06.2020 23:17

Составить программу которая поставит максимальный элемент массива на первое место(массив из 10 целых случайных чисел)

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Gllodory
01.10.2020 21:06
Var
  i,max,m:integer;
  a:array[1..10]of integer;
begin
writeln('Исходный массив:');
for i:=1 to 10 do
  begin
  a[i]:=random(50);
  write(a[i],' ');
  if a[i]>max then
     begin
     max:=a[i];
     m:=i;
     end;
  end;
writeln;
writeln('Измененный массив:');
i:=a[1];
a[1]:=a[m];
a[m]:=i;
for i:=1 to 10 do write(a[i],' ');
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота