ssqllxx
04.05.2023 18:47

Написать программу для массива ( c# ): п1. дан массив целых чисел из n элементов, заполненный случайным образом числами из промежутка [-10,20]. определить, есть ли в данном массиве положительные элементы, делящиеся на заданное число k

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
ViShEnKalкрасная
01.10.2020 20:23

//Для проверки результата вывел массив на экран

using System;

namespace App1

{

   class Program

   {

       private static void Main()

       {

           const int x = -10;

           const int y = 20;

           int n, k;

           Console.Write("Enter n: "); n = int.Parse(Console.ReadLine());

           Console.Write("Enter k: "); k = int.Parse(Console.ReadLine());

           Console.WriteLine($"{Environment.NewLine}Array:");

           int counter = 0;

           int[] array = new int[n];

           Random rand = new Random();

           for (int i = 0; i < array.Length; i++)

           {

               array[i] = rand.Next(x, y + 1);

               if (array[i] > 0 && array[i] % k == 0) { counter++; }

               Console.WriteLine($"{i + 1}. {array[i]}");

           }

           Console.Write(Environment.NewLine);

           if (counter > 0) { Console.WriteLine($"В массиве {counter} элементов, соответствующих заданному условию."); }

           else { Console.WriteLine("В массиве нет элементов, соответствующих заданному условию."); }

           Console.ReadKey();

       }

   }

}


Написать программу для массива ( c# ): п1. дан массив целых чисел из n элементов, заполненный случай
Написать программу для массива ( c# ): п1. дан массив целых чисел из n элементов, заполненный случай
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота