dinadaybert
08.11.2020 12:31

Написать программу в паскале и подробно описать присвойте z значение большего из x и y в том случае если x< 0 и меньшего если x> =0

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Ilonka2734
06.07.2020 11:27
Var x,y,z:integer; {описание переменных и их типа}
begin
writeln ('введи два числа'); {Вывод на экран сообщения-подсказки}
readln (x,y); {считывание переменных}
if x<0 then                      {проверка условия.}
  if y>x then z:=y             {если условие истинно, то мы ищем большее из х и у. если                                        у больше, то присваиваем z значение у}
           else z:=x             {если же больше х, то присваиваем его значение}
        else                        {если условие ложно}
           if y>x then z:=x     {то мы ищем меньшее из х и у. если                                                                           у больше, то присваиваем z значение х}
                    else z:=y;     {если же больше х, то присваиваем значение у}
writeln (z);                        {вывод результата на экран}
end.                                 {конец программы}
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота