dianochka471
15.12.2020 13:38

Решить на pascale! 1)составить программу вычисления в двумерном массиве минимального элемента, его номера и замены его на 100 2)записать в файл последовательность доступа n действительных чисел. найти разность первого и последнего компонентов файла 3)составить программу, удаляющую из предложения букву "е"

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
culi42
06.07.2020 11:23
Const n=7; m=8;
Var a:array[1..n,1..m] of integer;
i,j,x,y,min:integer;
begin
for i:=1 to n do begin
for j:=1 to m do begin
a[i,j]:=random(21)-10;
write(a[i,j]:4);
end;
writeln;
end;
min:=a[1,1];
x:=1;
y:=1;
for i:=1 to n do
for j;=1 to m do 
if a[i,j]<min then begin
min:=a[i,j];
x:=i;
y:=j;
end;
writeln ('минимальный элемент=',min,' он находился: ',x,',',y);
a[x,y]:=100;
for i:=1 to n do begin
for j:=1 to n do 
write (a[i,j]:4);
writeln;
end;
end.

3.Var s:string;
i:integer;
begin
writeln('Введи строку');
readln (s);
for i:=1 to length(s) do
if (s[i]='Е') or (s[i]='е') then delete(s,i,1);
writeln(s);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота