Массив содержит нечётное количество элементов.отсортировать первую половину массива по убыванию ,вторую по возрастанию.средний элемент заменить на ноль . составить программу на паскале
Честно, не поняла ваш код вообще. Почему нет цикла? Предлагаю свое решение: 1)Cначала заполняем массив случайными числами от 2 до 5 (включительно) 2)Потом выводим его (Для проверки) 3) Потом считаем оценки. Но сначала нужно обнулить переменные( В самом начале это делали), а то получится кака (:
program N_0547847; var b, c, d, f, i:integer; a: array [1..20] of integer; begin; randomize; b:=0; c:=0; d:=0; f:=0; for i:=1 to 20 do begin a[i]:=random(4)+2; write(a[i],' '); end; writeln; for i:=1 to 20 do begin if a[i]=2 then b:=b+1; if a[i]=3 then c:=c+1; if a[i]=4 then d:=d+1; if a[i]=5 then f:=f+1; end; writeln('Двоек: ', b); writeln('Троек: ', c); writeln('Четверок: ',d); writeln('Пятерок: ',f); end.
1) площадь изображения 35.56×35.56 = 1264.51 квадратных дюймов. количество точек в квадратном дюйме 1200×1200 = 1 440 000 точек количество точек во всем изображении 1 440 000 * 1264.51 = 182 089 440 000 глубина цвета 16 бит. 3 цвета RGB * 16 = 48бит на точку Итого 182089440000 * 48 = 8740293120000 бит 8740293120000 / 8 бит в байте / 1024 байт в КБ /1024 кб в мб / 1024 мб в гб = 865,39 Гигабайт
2) для палитры в 4 цвета небоходимо 2^n=4, n=2бита 55*55 = 3025 пикселя * 2 бита на пиксель = 6050бит
3) изображение 12,7×12,7 см. Разрешающая сканера — 600×1200 dpi, глубина цвета — 32 бита. в 1дюйме 2,54 см, 12,7см/2,54 см = 5 дюйм Изображение 5 * 5 = 25 квадратных дюймов 600*1200 = 720 000 точек на квадратный дюйм 720 000 * 25 = 18 000 000 точек на изображение
глубина цвета 32 бит. 3 цвета RGB * 32 = 96 бит на точку Итого 18 000 000 * 96 = 1 728 000 000 бит / 8 бит в байте = 216 000 000 байт
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку