diman211102
21.03.2021 04:42

Напишите программу, которая считывает с клавиатуры строку s и определяет, встречаются ли в строке s слова палиндромы. словом считается последовательность символов, ограниченная проьелами, и не имеющая пробелов внутри себя. строка s не пустая, содержит не более 200 символов и состоит только из строчных и прописных букв латинского алфавита и пробелов

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Chelyabin
01.10.2020 20:09
Var
 s,t:string;
 n,i:integer;
begin
write('Введите строку: ');
readln(t);
n:=1;
t:=t+' ';
for i:=2 to length(t) do
  if ((t[i]=' ') or (i=length(t)))  and (i-n>1) then
    begin
    s:=Copy(t,n,i-n);
    if s=ReverseString(s) then
      begin
      writeln('Да, палиндромы есть');
      halt
      end
        else n:=i+1
    end;
writeln('Палиндромов нет')    
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота