Chuclplllpl
19.08.2021 23:29

Составить программу вычисления высокой температуры за месяц

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
122344566
11.05.2023 08:04

Две задачи в одной программе:

#include <iostream>

#include <iomanip>

#include <ctime>

using namespace std;

int randInt(int min, int max){

       return min + (rand() % (max - min + 1));

}

int main(int argc, char *argv[]){

       const int DIM = 5;

       int matrix[DIM][DIM];

       const int Z = 0;

 

       srand(time(0));

 

       for (int i = 0; i < DIM; i++) {

               for (int j = 0; j < DIM; j++) {

                       matrix[i][j] = randInt(-5, 5);

                       cout << setw(4) << matrix[i][j] << ' ';

               }

               cout << endl;

       }

       cout << endl;

   

       cout << "x > " << Z << ":" << endl;

       int count = 0;

       int sum = 0;

       for (int i = 0; i < DIM; i++) {

               for (int j = 0; j < DIM; j++) {

                       if (matrix[j][i] > Z)

                               count++;

                       if (matrix[i][j] < 0)

                               sum += matrix[i][j];

               }

               cout << setw(4) << count << ' ';

               count = 0;

       }

       cout << endl;

       cout << endl;

       cout << "Sum: " << sum << endl;

       cout << endl;

       return 0;

}

По отдельности:

1)

#include <iostream>

#include <iomanip>

#include <ctime>

using namespace std;

int randInt(int min, int max){

       return min + (rand() % (max - min + 1));

}

int main(int argc, char *argv[]){

       const int DIM = 5;

       int matrix[DIM][DIM];

       const int Z = 0;

 

       srand(time(0));

 

       for (int i = 0; i < DIM; i++) {

               for (int j = 0; j < DIM; j++) {

                       matrix[i][j] = randInt(-5, 5);

                       cout << setw(4) << matrix[i][j] << ' ';

               }

               cout << endl;

       }

       cout << endl;

   

       cout << "x > " << Z << ":" << endl;

       int count = 0;

       for (int i = 0; i < DIM; i++) {

               for (int j = 0; j < DIM; j++) {

                       if (matrix[j][i] > Z)

                               count++;

               }

               cout << setw(4) << count << ' ';

               count = 0;

       }

       cout << endl;

       int sum = 0;

       for (int i = 0; i < DIM; i++) {

               for (int j = 0; j < DIM; j++) {

                       if (matrix[i][j] < 0)

                               sum += matrix[i][j];

               }

       }

       cout << "Sum: " << sum << endl;

       cout << endl;

 

       return 0;

}

2)

#include <iostream>

#include <iomanip>

#include <ctime>

using namespace std;

int randInt(int min, int max){

       return min + (rand() % (max - min + 1));

}

int main(int argc, char *argv[]){

       const int DIM = 5;

       int matrix[DIM][DIM];

       const int Z = 0;

 

       srand(time(0));

 

       for (int i = 0; i < DIM; i++) {

               for (int j = 0; j < DIM; j++) {

                       matrix[i][j] = randInt(-5, 5);

                       cout << setw(4) << matrix[i][j] << ' ';

               }

               cout << endl;

       }

       cout << endl;

   

       int sum = 0;

       for (int i = 0; i < DIM; i++) {

               for (int j = 0; j < DIM; j++) {

                       if (matrix[i][j] < 0)

                               sum += matrix[i][j];

               }

       }

       cout << "Sum: " << sum << endl;

       cout << endl;

       return 0;

}

0,0(0 оценок)
Ответ:
Aleksandra1111117
20.05.2023 23:01

Кожен алгоритм має справу з даними – вхідними, проміжними, вихідними

Алгоритм для розміщення даних вимагає пам'яті.

Алгоритм складається з окремих елементарних кроків, причому множина різних кроків, з яких складений алгоритм, скінченні.

Послідовність кроків алгоритму детермінована,

Алгоритм повинен бути результативним, тобто

Алгоритм передбачає наявність механізму реалізації,

Объяснение:

Вимога 1 відповідає цифровій природі ПК, вимога 2 – пам'ять ПК, вимога 3 – програмі машини, вимога 4 – її логічній природі, вимоги 5, 6 – обчислювальному пристрою та його можливостям.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота