Написать программу по "напишите программу получение из заданного целочисленного массива размером 30 элементов кол-во положительных, отрицательных и нулевых значений "
Program Adelia17; uses crt; const n=30; var matr:array [1..n] of integer; i,pos,neg,zero:integer; begin writeln('*** Alphaeus is thinking... ***'); writeln('*** OK ***'); writeln(); writeln(); writeln('Программа находит количество положительных, отрицательных и нулевых элементов массива'); pos:=0; neg:=0; zero:=0; randomize; writeln('Массив: '); for i:=1 to n do begin matr[i]:=random(100)-50; write(matr[i]:4,' '); if matr[i]>0 then pos:=pos+1; if matr[i]<0 then neg:=neg+1; if matr[i]=0 then zero:=zero+1; end; writeln(); writeln('Количество положительных элементов равно ',pos); writeln('Количество отрицательных элементов равно ',neg); writeln('Количество нулевых элементов равно ',zero); end.
Const N = 30; Var a:array [1..N] of integer; b,c,d,i:integer; begin Writeln('Vvedite massiv'); for i:=1 to N do readln(a[i]); b:=0; c:=0; d:=0; for i:=1 to N do begin if a[i] = 0 then inc(b); if a[i] > 0 then inc(c); if a[i] < 0 then inc(d); end; writeln('Kol-vo ravnih 0 - ',b); writeln('Kol-vo bolshe 0 - ',c); writeln('Kol-vo menshe 0 - ',d); readln; end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку