dahasha0515ozg6qu
15.09.2020 11:51

Паскаль напишите программу, которая 10 раз запрашивает ввод целого числа. при завершении ввода на экран выводится сумма чисел, минимальное число, максимальное число.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
akinfijevsp058du
01.10.2020 20:07
Program Lana132;
uses crt;
const n=10;
var
  i,ch,max,min,sum:integer;
begin
  writeln('*** Alphaeus is thinking... ***');
  writeln('***          OK             ***');
  writeln(); writeln();
  writeln('Программа запрашивает N чисел, находит их сумму, максимальное и минимальное число');
  sum:=0;
  write('Введите 1-e число: '); read(ch);
  sum:=sum+ch;
  max:=ch; min:=ch;
  for i:=2 to n do
    begin
      write('Введите ',i,'-e число: '); read(ch);
      sum:=sum+ch;
      if max<ch then max:=ch;
      if min>ch then min:=ch;
   end;
  writeln('Сумма всех чисел равна ',sum);
  writeln('Максимальное число равно ',max);
  writeln('Минимальное число равно ',min);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота