simone1311
25.05.2023 13:54

дана информация о температуре воздуха за январь. написать программу, которая: а)определит сколько раз температура опускалась ниже 0 градусов б)определит среднюю температуру за январь

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Кратосчелавек
01.10.2020 19:54
Var
   st:real;
   i,n:integer;
   t:array[1..31]of integer;
begin
writeln('Температура в январе:');
for i:=1 to 31 do
  begin  t[i]:=random(-10,5);
  write(t[i],' ');
  st:=st+t[i];
  if t[i]<0 then n:=n+1
  end;
st:=st/31;
writeln;
writeln('Число дней с отр.температурой: ',n);
writeln('Средняя температура: ',st:1:1)
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота