30kotenok04
15.03.2021 10:44

Составить программу которая будет находить сумму отрицательных чётных элементов одномерного массива. используя процедуры

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
kris0287
06.07.2020 06:19
Var
  i,s:integer;
  a:array[1..10]of integer;
procedure sum(a:integer; var s:integer);
begin
if (a mod 2=0) and (a<0) then
   s:=s+a
end;
begin
write('Массив: ');
for i:=1 to 10 do
  begin
  a[i]:=random(-10,10);
  write(a[i],' ');
  sum(a[i],s)
  end;
writeln;
writeln('s=',s)
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота