Войти
Регистрация
Спроси ai-bota
Franker10
13.10.2021 02:46
Взаданном массиве а [1: n] положительные элементы уменьшите в двое,а отрицательные замените на значение их индексов. на си,
Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
slojnaa
20.08.2021 04:57
Объяснить разницу между read и readln, аналогично с write и writeln....
arhivnaykr
25.09.2022 02:06
Какие вы знаете устройства хранения информации?...
gggggerrrr
11.08.2020 04:12
Ввести число k, если оно чётное , то нарисовать красный круг , нечётное зелёный квадрат (ветвление информатика молю ...
Litoli
15.07.2022 18:49
Задание № 5. 1. Запустить текстовый редактор Word командой [Программы-Microsoft Word].2. Ввести команду [Вставка-Символ...]. На экране появится диалоговая панель Символ Центральную...
ученикB
12.09.2021 19:58
Вид величини - цеконстанта або зміннаназва, що вільно обирається програмістом для елементів програми| |множина допустимих значень величиникететдома сигнал б використання...
Вероника13411
27.05.2020 00:17
Величина – це... *Константаназва змінноїзначення змінноїокремий інформаційний об єкт...
kotflin
24.01.2023 04:25
Нарисуйте блок схему и напише программу для подсчёта сумму и произведения чисел вводимого числа. ...
Violent111
30.10.2020 00:33
1. web-страницы имеют расширение: а) *.htm; б) *.txt; в) *.web; г) *.exe; д) *.www. 2. для подключения к сети надо иметь а) модем; б) принтер; в) сканер; г) сетевую...
Семма0106
30.10.2020 00:33
1. база данных - а) специальный пакет программ, обеспечивающий создание, сопровождение и использование баз данных многими пользователями; б) программа, обеспечивающая...
Galerina
31.01.2020 02:22
Написать программу, которая бы по введенному номеру единицы измерения (1 — килограмм, 2 — миллиграмм, 3 — грамм, 4 — тонна, 5 — центнер) и массе М выдавала соответствующее...
Ответ:
дззззззззззззззззз
05.07.2020 23:25
/*в заданном массиве А [1:N] положительные элементы уменьшить в двое,отрицательные заменить на значение их индексов*/
#include <stdio.h>
#include <stdlib.h>
int main()
{
int N; // Размер массива
int i; // Индекс
system("chcp 1251 > nul"); // Кодировка
printf("%s", "Введите N: ");
scanf("%d", &N);
int A[N];
printf("%s %d %s\n" , "Введите", N ,"элементов:");
for(i = 0; i < N; i++)
{
scanf("%d", &A[i]); // Считывание элем. массива, сравнение и присвоение
if (A[i] > 0) A[i] *= 2;
if (A[i] < 0) A[i] = i;
}
printf("%s", "Результат: ");
for(i = 0; i < N; i++)
printf("%d ", A[i]);
sytem("pause"); // Пауза
return 0;
}
0,0
(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота