cherbycorTaiga
17.08.2021 07:19

Составить программу, которая упорядочивает элементы четных строк по возрастанию,а нечетных по убыванию.матрица размером 8х8.полученную матрицу напечатать.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
kulaevmasya
05.07.2020 22:53
Var
   i,j,k,p:integer;
   a:array[1..8,1..8]of integer;
begin
writeln('Исходный массив:');
for i:=1 to 8 do
begin 
for j:=1 to 8 do
    begin   
    a[i,j]:=random(20);
    write(a[i,j]:3)
    end;
    writeln
end;
for i:= 1 to 8 do
     for j:= 1 to 8 do
     for k:= 1 to 8 do
        begin
        if i mod 2=0 then
           begin
           if (a[i,j]<a[i,k]) then
              begin
              p:=a[i,j];
              a[i,j] := a[i,k];
              a[i,k] := p
              end
           end
           else
              if a[i,j] > a[i,k] then
                 begin
                 p:=a[i,j];
                 a[i,j] := a[i,k];
                 a[i,k] := p
                 end
       end;
writeln('Преобразованный массив:');
for i:=1 to 8 do
   begin
   for j:=1 to 8 do
      write(a[i,j]:3);
   writeln
   end;
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота