sonyaunicorn1
10.06.2021 06:56

Pascal ) надо составить программу в паскале, где в двумерном массиве вычисляется количество нулей на главной диагонали. завтра сдавать надо( в интернете не нашла ничего толкового..

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
ANNAAFANASYEVA1
05.07.2020 20:55
Var
   i,j,s:integer;
   a:array[1..10,1..10]of integer;
begin
writeln('Исходный массив:');
for i:=1 to 10 do
  begin
  for j:=1 to 10 do
    begin
    a[i,j]:=random(-10,10);
    if (a[i,j]=0) and (i=j) then s:=s+1;
    write(a[i,j]:3)
    end;
  writeln
  end;
writeln('Число нулей на главной диагонали: ',s)
end.
0,0(0 оценок)
Ответ:
kirillkosyarev
05.07.2020 20:55
Решение задачи на PascalABC (листинг программы по ссылке, сейчас ее попробую передать)
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота