dranithkindana
27.10.2020 00:07

Дан целочисленный массив с количеством элементов n. выведете на печать те его элементы. индексы которых являются степенями двойки. написать программу в паскале

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
9639933p08o1o
05.07.2020 14:58

program raf105;

const

 n = 99;

var

 a: array[1..n] of integer;

 i,i2: integer;

begin

 write('Исходный массив: ');

 for i:= 1 to n do

 begin

   a[i]:= random(10,99);

   write(a[i],' ');

 end;

 writeln;

 writeln('Вывод: ');

 for i:=2 to n do

 begin

   i2:= i;

   while (i2 mod 2 = 0) and (i2 <> 0) do

     i2:= i2 div 2;

   if i2 = 1

     then writeln(a[i]:2,' (индекс ',i:2,')');

 end;

end.

PascalABC
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота