Anacmasnz106
14.01.2022 03:33

Написать программу в паскале: даны целое n> 0 и последовательность из n вещественных чисел, среди которых есть хотя бы одно отрицательное число. найти величину наибольшего среди отрицательных чисел этой последовательности.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Арбузярик
05.07.2020 14:15
Var
  x,max:real;
  n,i:integer;
begin
write('Введите число n: ');
readln(n);
for i:=1 to n do
  begin
  write('Введите число ',i,': ');
  readln(x);
  if x<0 then
     begin
     if max=0 then max:=x;                     // если это первое отр.число
     if x>max then max:=x
     end
  end;
writeln('Наибольшее среди отрицательных: ',max)
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота