ЕваКимСокДжин
02.08.2022 02:58

Написать программу в паскаль. дан массив целых чисел, состоящий из 20 элементов. заполнить его датчиком случайных чисел. заменить максимальный элемент на противоположный по знаку.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
MegaTanker
05.07.2020 12:25
Program chik;
const n=20;
var a:array[1..20]of integer;
i,l,max:integer;
begin
randomize;
for i:=1 to n do
a[i]:=random(100)-50;
max:=a[1];
for i:=2 to n do
if(a[i]>max)then max:=a[i];
for i:=1 to n do
begin
if(a[i]=max)then a[i]:=-max;
write(a[i],' ');
end;
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота