polina359674
14.08.2020 06:07

По паскалю.условный оператор. 1.даны два действительных числа меньшее из них замените полусуммой их, а большее их произведением. 2.найдите решение уравнения ах+ в=0, если оно существует,если а=0 3.написать программу удвоения меньшего из двух чисел

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
SweetCandy23228
01.10.2020 19:09
1)
program chik2;
var a,b,c:real;
begin
readln(a,b);
if(a<b)then begin
c:=a;
a:=(a+b)/2;
b:=b*c;
end;
if(a>=b)then begin
c:=b;
b:=(a+b)/2;
a:=a*c;
end;
writeln(a,' ',b);
end.
2)
program chik;
var a,x,b:real;
begin
readln(a,b);
if(a=0)and(b<>0)then writeln('НЕТ решений');
if(a<>0)then begin
 x:=-b/a;
writeln(x);
end;
end.
3)

program chik3;
var a,b:real;
begin
readln(a,b);
if(a<b)then a:=a*2 else
if(b<a)then b:=b*2;
writeln(a,' ',b);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота