марс56
01.12.2021 01:18

Напишите программу на паскале ax^2+bx+c< 0

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
verachistova1
01.10.2020 18:57
Program a1;
var a,b,c,x,x1,x2,d:real;
begin 
write('Введите а '); read(a);
write('Введите b '); read(b);
write('Введите c '); read(c); 
begin  
d:=sqr(b)-4*a*c; 
if d<0 then  
begin    
write('Нет корней');   
end 
else    
begin    
if d=0 then     
begin      
x:=-b/(2*a);     
write('x=' , x);     
end   
else      
begin      
x1:=(-b+sqrt(d))/(2*a);     
x2:=(-b-sqrt(d))/(2*a);     
write('x1=',x1,'x2=',x2);     
end;     
end;     
end;     
end.            
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота