popovichmilanap06lkc
11.11.2022 07:11

Напишите программу(паскаль), которая считывает с клавиатуры последовательность символов и выводит на экран количество нечетных цифр : с

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
an2015tep071hf
05.07.2020 06:47
Var
n, k, a, i: integer;

begin
write('Введите кол-во чисел: ');
readln(n);
for i:=1 to n do
 begin
 read(a);
 if ((a mod 2) = 1) then inc(k);
end;
write(k);
end.

С использованием оператора repeat:

var
n, k, a, i: integer;
begin
write('Введите кол-во чисел: ');
readln(n);
repeat
 read(a);
 if ((a mod 2) = 1) then inc(k);
 inc(i);
 until i=n;
write(k);
end.

 n - кол-во чисел, k - кол-во нечётных чисел, a - число
Все числа вводятся через пробел
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота