derkioptu
01.07.2021 17:31

Написать программы на python! 1) напишите программу, которая в последовательности целых чисел определяет их количество и сумму четных чисел. программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0-признак окончания ввода, не входит в последовательность). количество чисел не превышает 1000. введённые числа по модулю не превышают 30000. программа должна вывести два числа : длину последовательности и сумму чётных чисел. 2)напишите программу, которая в последовательности целых чисел определяет сумму двух наибольших и сумму двух наименьших. программа должна вывести две этих суммы в указанном порядке. программа получает на вход целые числа, количество введённых чисел не известно, последовательность чисел заканчивается числом 0 (0 — признак окончания ввода, не входит в последовательность). количество чисел не превышает 1000. введённые числа по модулю не превышают 30 000.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Melisaoz07
26.06.2022 01:23
Так как в задании не указано, что введенное слово должно обрамляться пробелами, то код может быть такой:

var s,a:string;
    begin
    write('Введите строку : ');
    readln(s);
    write('Введите слово : ');
    readln(a);
       if(pos(a, s) <> 0) then writeln('Слово "',a,'" в строке есть')
       else writeln('В строке такого слова нет');
    end.

Тест №1
Введите строку : Привет участникам олимпиады!
Введите слово : ник
Слово "ник" в строке есть

Тест №2
Введите строку : Всем привет!
Введите слово : админ
В строке такого слова нет
0,0(0 оценок)
Ответ:
kthjxrfqqq
11.07.2020 01:49
//PascalABC.NET (версия 3.1, сборка 1210 от 29.03.2016)
{
Определения длины средней линии трапеции,
если известны длины оснований трапеции.
}
var
  a,b : real;

begin
  readln(a,b);
  writeln('длина средней линии = ',(a+b)/2);
end.

{
 Вычисления площади трапеции,
 если известны ее основания и высота.
}
var
  a,b,h : real;

begin
  readln(a,b,h);
  writeln('площадь трапеции = ',(a+b)/2*h);
end.

{
 Вычисления расстояния между
 двумя точками на координатной плоскости
}
var
  x1,y1,x2,y2 : real;

begin
  write('Координаты 1 точки '); readln(x1,y1);
  write('Координаты 2 точки '); readln(x2,y2);
  writeln('Расстояние между точками = ',sqrt(sqr(x1-x2)+sqr(y1-y2)));
end.

{
 Вычисления периметра треугольника,
 если известны координаты его вершин
}
var
  x1,y1,x2,y2,x3,y3,a,b,c : real;

begin
  write('Координаты 1 вершины '); readln(x1,y1);
  write('Координаты 2 вершины '); readln(x2,y2);
  write('Координаты 3 вершины '); readln(x3,y3);
  a:=sqrt(sqr(x1-x2)+sqr(y1-y2));
  b:=sqrt(sqr(x3-x2)+sqr(y3-y2));
  c:=sqrt(sqr(x3-x1)+sqr(y3-y1));
  writeln('периметр треугольника = ',a+b+c);
end.

{
 В углу прямоугольного двора размером a*b стоит
 прямоугольный дом размером c*d.
 Подсчитать площадь дома,
 свободную площадь двора и длину забора.
}
var
  a,b,c,d,sh : real;

begin
  write('Размеры двора '); readln(a,b);
  write('Размеры дома '); readln(c,d);
  sh:=c*d; //площадь дома
  writeln('площадь дома = ',sh);
  writeln('свободная площадь двора = ',a*b -sh);
  writeln('длина забора = ',(a+b)*2 -(c+d));
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота