nkartalev
24.01.2022 06:11

C++ builder написать программу информацию о докторах клиники написать программу информацию о футбольных клубах написать программу информацию о цвете (типо кнопка с наименованием "красный" показывал красный цвет при нажатии)

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
ГКПС
14.03.2023 11:10
Проверено на fpc 3.0.0

const
  m=6; // строк
  n=9; // столбцов
var
  a:array[1..m,1..n] of integer;
  i,j,k1,k2,s,k:integer;
begin
  Writeln('Введите границы диапазона: '); Read(k1,k2);
  Randomize;
  s:=0; k:=0;
  for i:=1 to m do begin
    for j:=1 to n do begin
      a[i,j]:=Random(199)-99; // [-99;99]
      Write(a[i,j]:4);
      if (a[i,j]>=k1) and (a[i,j]<=k2) then begin
        Inc(k); s:=s+a[i,j]
        end
      end;
    Writeln
    end;
  Writeln('Отобрано элементов: ',k,', их сумма равна ',s)
end.
 
Пример
Введите границы диапазона:
-20 55
  -2 -52 -11 -12  70 -15  90 -51  75
 -54 -92  32  54 -72 -24 -40 -37 -20
   0 -14 -79  -1 -39 -34  39  47  34
 -91 -98 -68 -16 -56 -55  97  66  59
 -48 -67 -34  92 -77  12 -67 -23 -90
  75  85  65 -98 -58 -53  -6  34  33
Отобрано элементов: 18, их сумма равна 188

Фпс. дан двумерный массив. найти сумму и количество элементов, в числовой интервал от kl до k2
0,0(0 оценок)
Ответ:
lianochkaya14
03.02.2021 14:07
Const m=5;
var 
a:array[1..m,1..m] of integer;
i,j:integer;
begin
Randomize;
writeln('Исходный массив:');
for i:=1 to m do
 begin
 for j:=1 to m do
  begin
  a[i,j]:=random(100);
  write(a[i,j]:4);
  end;
 writeln;
 end;
for i:=2 to m do
 for j:=1 to i-1 do
   a[i,j]:=0; 
writeln('Полученный массив:');
for i:=1 to m do
 begin
 for j:=1 to m do write(a[i,j]:4);
 writeln;
 end;
end.

Пример:
Исходный массив:
  12  76  20  65  71
  27  52  36  45  52
   9  69   8  69  46
  89  69  52  76  31
  71  25   7  62  89
Полученный массив:
  12  76  20  65  71
   0  52  36  45  52
   0   0   8  69  46
   0   0   0  76  31
   0   0   0   0  89
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота