Jama133
22.08.2022 03:15

По данным x, y составить программу в паскале для вычисления функции z: 1) z=(min(x, y)+0,5))/(1+max^2(x, 2)z=система max(x, y), x< 0 min(x, y), x> =0.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Dashad27
03.07.2020 10:02
1)var x,y,z,min,max:real;
begin
readln(x,y);
if x>y then 
begin
max:=x;
min:=y;
end
else if x<y then
begin
max:=y;
min:=x;
end;
z:=(min+0.5)/(1+sqr(max));
writeln(z);
end.
2)var x,y,z,min,max:real;
begin
readln(x,y);
if x>y then
begin
max:=x;
min:=y;
end
else if x<y then
begin
max:=y;
min:=x;
end;
if x<0 then
z:=max
else if x>=0 then
z:=min;
writeln(z);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота