Fan111111
08.02.2022 19:42

Напишите программу которая определяет nod трех натуральных чисел (с использованием процедур)

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
yufhdg
03.07.2020 08:46
Var
 a,b,c:integer;
procedure main(a,b,c:integer);
var
 i,max,nod:integer;
begin
 if (a>b) and (a>c) then
  max:=a
 else
  if (b>a) and (b>c) then
   max:=b
  else
   max:=c;
 nod:=1;
 for i:=1 to max do
 begin
  if (a mod i = 0) and (b mod i = 0) and (c mod i = 0) then
   nod:=i;
 end;
 writeln(nod);
end;
begin
 read(a,b,c);
 main(a,b,c);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота