Напишите программу на языке паскаль, которая вычесляет сумму: а) первых n натуральных чисел; б) квадратов первых n натуральных чисел; в) всех чётных чисел в диапазоне от 1 до n; г) всех двузначных чисел.
for i := 1 to n do begin s1 := s1 + i; s2 := s2 + sqr(i); if i mod 2 = 0 then s3 := s3 + i; end;
for i := 10 to 99 do s4 := s4 + i;
writeln('Сумма первых n натуральных чисел: ', s1); writeln('Сумма квадратов первых n натуральных чисел: ', s2); writeln('Сумма всех четных чисел: ', s3); writeln('Сумма всех двухзначных чисел: ', s4); end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку