Ffffffsusjbshjxj
27.06.2022 00:26

Нужно составить программу, вычисляющую сумму только положительных чисел из трех вводимых с клавиатуры. в турбо паскале

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
SpiritAlice
01.10.2020 16:45
Program picaso; uses crt;
var a,b,c,s:integer;
begin clrscr;
writeln('A:');read(a);
writeln('B:');read(b);
writeln('C:');read(c);
if(a > 0) then a:=a else a:=0;
if(b > 0) then b:=b else b:=0;
if(c > 0) then c:=c else c:=0;
s:=a+b+c;
writeln(s);
readln;
end.
0,0(0 оценок)
Ответ:
annelya009
01.10.2020 16:45
Var a,b,c,ap,bp,cp:real;
begin
read(a,b,c);
if a>0 then ap:=a else ap:=0;
 if b>0 then bp:=b else bp:=0;
 if c>0 then cp:=c else cp:=0;
write  (ap+bp+cp);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота