jasulau
29.06.2022 12:02

Составьте программу, определяющую номер координатной четверти, в которой находится точка с координатами(х,y). если точка лежит на оси координат или в начале координат, то выведите соответствующее сообщение. числа х,y вводятся с клавиатуры. желательно с объяснением.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
9276
01.10.2020 16:26
Pascal:

var x,y:integer;
begin
readln (x,y);
if (x>0) and (y>0) then writeln ('Точка лежит в первой четверти');
if (x<0) and (y>0) then writeln ('Точка лежит во второй четверти');
if (x<0) and (y<0) then writeln ('Точка лежит в третьей четверти');
if (x>0) and (y<0) then writeln ('Точка лежит в четвертой четверти');
if (x=0) and (y=0) then writeln ('Точка лежит на пересечении осей') else
if x=0 then writeln ('Точка лежит на оси ординат') else if y=0 then writeln ('Точка лежит на оси абсцисс');
readln;
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота