Ванесса07
30.09.2020 15:35

Дано трехзначное число. напишите программу, которая определяет: а) есть ли среди цифр заданного целого трехзначного числа одинаковые пример входных данных: пример выходных данных: 123 нет 121 да 222 да

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
PROmax100
01.10.2020 16:06
Ну если я правильно понял то что тут написано то вот на pascal'e.. )
Var n,a,b,c:byte;
begin readln(n);
a:=n mod 10;
n:=n div 10;
b:=n mod 10;
n:=n div 10;
c:=n mod 10;
if (a=b) or (a=c) or(b=c) then writeln('да') else writeln('нет');
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота