sidyakinanasty
23.10.2022 16:01

Написать программу на паскале дана квадратная матрица размером . найти сумму главной диагонали и умножить на полученное число все элементы матрицы, кроме лежащих на главной диагонали

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
карина4556
02.07.2020 08:48

program raf105;

const

 n = 4;

var

 a: array[1..n,1..n] of integer;

 i,j,sum: integer;

begin

 for i:=1 to n do

 begin

 writeln;

   for j:=1 to n do

     begin

       a[i,j]:= random(1,9);

       if i = j then

         sum:= sum + a[i,j];

       write(a[i,j]:4,' ');

     end;

 end;

 writeln;

 writeln;

 writeln('Вывод:');

   for i:=1 to n do

 begin

 writeln;

   for j:=1 to n do

     begin

       if i <> j then

         a[i,j]:= a[i,j] * sum;

       write(a[i,j]:4,' ');

     end;

 end;

end.

PascalABC 3.4.2
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота