skyblue1
06.09.2020 11:22

Нужно составить программу для этих рисунков в кумире! 50

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
kiriolet
10.05.2022 22:32
Если число заканчивается на 5 или 0, то по признакам делимости оно кратно 5.

1. Глупый школьный вариант

Перебираем все числа в заданном диапазоне и если встречаем кратное 5, прибавляем его к сумме.

var
  i,s:integer;

begin
  s:=0;
  for i:=1 to 200 do
    if i mod 5=0 then s:=s+i;
  Writeln(s)
end.

Результат:
4100

2. Более умный школьный вариант с циклом while

Первое число, кратное 5 - это 5. А дальше прибавляем по 5 к сумме и ничего не нужно проверять.

var
  i,s:integer;

begin
  i:=5; { первое подходящее число }
  s:=i;
  while i<200 do begin
    i:=i+5;
    s:=s+i
    end;
  Writeln(s)
end.

3. Еще более умный школьный вариант с циклом for

От предыдущего отличается получения нужных чисел.
Замечаем, что ряд 5, 10, 15, 20, ... можно получить из чисел 1, 2, 3, 4, ..., умножая их на 5. И таких чисел будет 40.

var
  i,s:integer;

begin
  s:=0;
  for i:=1 to 40 do s:=s+5*i;
  Writeln(s)
end.

4. Современный вариант на современном Паскале

Генерируем последовательность нужных чисел и находим сумму её элементов.

// PascalABC.NET 3.3, сборка 1625 от 17.01.2018
// Внимание! Если программа не работает, обновите версию!

begin
  Range(5,200,5).Sum.Println
end.
0,0(0 оценок)
Ответ:
Annnnnnnnnnнnna
27.10.2022 22:06

s:=0; х:=1385

while x > 0 do begin

1) s:= s + x mod 2 = 1 ;

x:= x div 10 = 138;

2) s:= s + x mod 2 = 1 ;

x:= x div 10 = 13;

3) s:= s + x mod 2 = 2 ;

x:= x div 10 = 1;

4) s:= s + x mod 2 = 3 ;

x:= x div 10 = 0;

write(s); // s = 3

write(x); //х = 0

end

Объяснение:

x mod 2 - остаток после деления х на 2

x div 10 - целое число, которое осталось после деления х на 10

s:=0; х:=1385  - изначальные данные

while x > 0 do begin  - "продолжать пока х > 0"

//комментарий на строке

write() - вывод переменной в скобке

s:=0; х:=1385

while x > 0 do begin

1) s:= s + x mod 2 = 0 + 1 = 1 ;

x:= x div 10 = 1385:10 =  138 (ост. 5 не пишется);

2) s:= s + x mod 2 = 1 + 0 = 1 ;

x:= x div 10 = 138:10 = 13 (ост. 8 не пишется);

3) s:= s + x mod 2 = 1 + 1 = 2 ;

x:= x div 10 = 13:10 = 1 (ост. 3 не пишется);

4) s:= s + x mod 2 = 2 + 1 = 3 ;

x:= x div 10 = 1:10 = 0 (ост. 1 не пишется);

end

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота