kottonkandy
11.03.2020 17:36

Решить с паскаля две : 1. составить программу, которая содержит функцию и которая определяет, верно ли, что сумма цифр числа является четным числом. 2. составить программу, которая определяет,верно ли, что в заданном числе все цифры стоят по возрастанию.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
vladimir00041
01.07.2020 10:47
Program gt;
var n:integer;
function chik(n:integer):integer;
var s,q:integer;
begin
s:=0;
while n>0 do
begin
q:=n mod 10;
n:=n div 10;
s:=s+q;
end;
chik:=s;
end;
begin
read(n);
if(chik(n) mod 2=0)then writeln('yes')else writeln('no');
end.
2)
program gt;
var n,q,k,r:integer;
begin
read(n);
k:=0;r:=-1;
while n>0 do
begin
q:=n mod 10;
n:=n div 10;
if(q>=r)and(r<>-1)then k:=1;
r:=q;
end;
if(k=0)then writeln('yes')else writeln('no');
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота