saa20
20.05.2021 03:17

Напишите следующую программу. введите с клавиатуры целое число n. выведите на экран числа от 1 до n так, чтобы каждое число выводилось столько раз, каково его значение. например, если с клавиатуры введено 6, то на экране мы должны увидеть: 1 2 2 3 3 3 4 4 4 4 5 5 5 5 5 6 6 6 6 6 6 написать программу нужно как можно проще в программе pascalabc

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Arinakap22
01.07.2020 10:17
Вообщем, сделал задачу, но метод пузырька уже не выйдет :) т.е. сортировка по возрастанию :( упрощал как мог.

Program asd;
USES crt;
Var n,m,i,j:integer;
BEGIN
Clrscr;
Writeln('Введите число n: ');
Readln(n);
n:=n+1;
For i:=1 to n do 
 begin n:=n-1; 
   For j:=1 to n  do   
     begin   
      Write(n:3); 
     end; 
end;
END.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота