zalikmap08ic7
16.08.2022 15:02

Составить программу, которая запрашивает у пользователя целое двухзначное число и прибавляет к нему сумму его цифр.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
zuste
24.05.2020 23:24

Program n1;
Uses CRT;
Var x,a,b: integer;
begin
ClrScr;
writeln('Vvedite x');
readln(x);
a:=x div 10;
b:=x mod 10;
Writeln(x,'+',a,'+',b,'=',x+a+b);
readln
end.

0,0(0 оценок)
Ответ:
Dinochka99
24.05.2020 23:24

var a: 10..99;

begin

  readln(a);

  writeln(a+(a mod 10)+(a div 10));

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота