bomixov
16.08.2022 15:02

Паскаль 1) составить программу, которая определяет произведение цифр четырехзначного числа, введенного пользователем. 2) составить программу, которая по формулам для арифметической прогрессии находит сумму n первых элементов прогрессии и значения трех элементов с номерами (n–1), n и (n+1). число n, первый элемент и разность прогрессии вводятся пользователем. вывести значения элементов в форме таблицы, где первая строка – номер, а вторая – значение.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Gcxvh
24.05.2020 23:23

1)

var a: 1000..9999;

      a1, a2, a3, a4: 1..9;//Цифры числа

begin

  writeln('Введите четырехзначное число');

  readln(a);

  a4:= a mod 10; //Последняя цифра

  a3:= (a mod 100) div 10;

  a2:= (a mod 1000) div 100; 

  a1:=a div 1000;//Первая слева цифра

  writeln('Произведение цифр числа: ',a1 * a2 * a3 * a4);

end.

2)

var

  n: integer;

  d, s: real;

  a1: real;

begin

  writeln('Введите число n');

  readln(n);

  writeln('Введите разность прогрессии');

  readln(d);

  writeln('Введите первый элемент');

  readln(a1);

  s:= ((2*a1+d*(n-1))/2)*n;

  writeln('Номер: ', n-1, '     Значение: ', a1+d*(n-2));

  writeln('Номер: ', n, '     Значение: ', a1+d*(n-1));

  writeln('Номер: ', n+1, '     Значение: ', a1+d*n);

  writeln('Сумма ', n, ' первых элементов равна: ',S);

end.

          

  

 

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота