Medina20161102
27.06.2020 21:52

Составьте программу которая а)выполняет операцию сцепления трех введенных с клавиатуры символов б)выполняет операцию сцепления трех введенных с клавиатуры символов и выводит результат сравнения на экран. например 'a'< 'б', 'д'='д, 'я'> 'ы' в) выполняет сравнение двух введенных с клавиатуры символов и выводит их на экран в порядке вохрастания их кодов

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
svesda2
24.05.2020 23:18

а), б)

var a, b, c: char;

begin

  writeln('Введите 3 символа');

  readln(a, b, c);

  writeln('Результат сцепления: ', a+b+c);

  if a>b then writeln(a,'>', b);

  if a>c then writeln(a,'>', c);

  if a=b then writeln(a, '=', b);

  if a=c then writeln(a, '=', c);

  if a<b then writeln(a, '<', b);

  if a<c then writeln(a, '<', c);

  if b>c then writeln(b, '>', c);

  if b<c then writeln(b, '<', c);

end.

в)

var a, b: char;

begin

  writeln('Введите 2 символа');

  readln(a, b);

  if a>b then writeln(b,'  ', a);

  if a<b then writeln(a,'  ', b);

  if a=b then writeln(a,'  ', b);

end.

  

   

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота