Mollи
28.11.2022 11:11

Напишите программу, которая циклически сдвигает элементы массива вправо (например, если элементы нумеруются, начиная с нуля, то 0-й элемент становится 1-м, 1-й становится 2-м, последний становится 0-м, то есть массив {3, 5, 7, 9} превращается в массив {9, 3, 5, 7}). входные данные сначала задано число n — количество элементов в массиве (1n35). далее через пробел записаны n чисел — элементы массива. массив состоит из целых чисел. на c# .у кого есть ответы всех

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
ivanBashak1
12.04.2022 05:18
Const   n = 5; var   i: integer;   a: array[1..n * 2 + 1] of integer; begin   writeln('исходный массив: ');   for i : = 1 to 2 * n do   begin       a[i] : = random(99) + 1;       write(a[i] : 5);   end;   for i : = 2 * n + 1 downto n + 1 do       a[i] : = a[i - 1];   a[n + 1] : = 0;   writeln();   writeln('полученный массив: ');   for i : = 1 to 2 * n + 1 do       write(a[i] : 5); end.
0,0(0 оценок)
Ответ:
nata12377
03.03.2020 12:08

#include <iostream>

#include <cmath>

using namespace std;

int main()  

{

 int first, second, temp;

 cin >> first >> second;

 if (first > second)

 {

   temp = first;

   first = abs(first * second);

   second = abs(temp - second);

 }

 else

 {

   temp = second;

   second = abs(second * first);

   first = abs(temp - first);

 }

 cout << first << " " << second;

}

Объяснение:

#include <iostream>  // Библиотека ввода - вывода

#include <cmath>  // Библиотека с математическими функциями

using namespace std;  // Пространство имен

int main()  

{

 int first, second, temp;  // Создание целочисленных переменных:

first - первое число, вводимое с клавиатуры;second - второе число, вводимое с клавиатуры;temp - переменная, для временного хранения одного из значений.

 cin >> first >> second;  // Вводим с клавиатуры первое и второе числа

 if (first > second)  // Если значение переменной first > значения переменной second

 {

   temp = first;  // Переменная временного хранения = значению переменной first

   first = abs(first * second);  // Значение переменной first (большей) = модулю произведения двух чисел

   second = abs(temp - second);  // Значение переменной second (меньшей) = модулю разности двух чисел

 }

 else  // Иначе

 {

   temp = second;  // Переменная временного хранения = значению переменной second

   second = abs(second * first);  // Значение переменной second (большей) = модулю произведения двух чисел

   first = abs(temp - first);  // Значение переменной first (меньшей) = модулю разности двух чисел

 }

 cout << first << " " << second;  // Выводим значения переменных first и second

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота