lenapOLD
02.01.2023 10:30

Написать программу для нахождения а) нод, б) нок двух натуральных чисел а, b.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Бетти2004
28.06.2020 20:59
Program gt1;
var m,n,q,r,t:longint;
begin
read(m,n);
t:=m*n;
r:=1;
while r<>0 do
begin
q:=m div n;
r:=m mod n;
if (r<>0)then begin
m:=n;
n:=r;
end;
end;
t:=t div n;
write(n,' ',t);
end.
t-НОК
n-получившиеся НОД
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота