06637381
05.10.2022 09:39

1. написать программу для решения : точки на плоскости заданы своими координатами. определить какая из них находится ближе к началу координат.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
olgaocher
01.10.2020 14:11
Uses crt;
var n,minind,i:integer;
min,x,y:real;
begin
writeln('Введите количество точек: ');
read(n);
writeln('Вводите по очереди координаты x и y точек.');
read(x,y);
min:=sqr(x)+sqr(y);
minind:=1;
for i:=2 to n do
begin
read(x,y);
if sqr(x)+sqr(y)<min then
begin
min:=sqr(x)+sqr(y);
minind:=i;
end;
end;
writeln('Точка под номером ',minind,'.');
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота